Manitoba Hunting Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
I have a Delta 8 and have been using it quite a bit but am having a problem with it now and then. Some of the pictures come out with the whole image a pure white. Maybe every 10 pictures or so are like this. I am thinking something was too close and the flash causes this. Not sure.

Any else have experiences like this with any cams? I only started using the camera last fall so I am kinda new to what to expect from them.
 

·
Registered
Joined
·
389 Posts
No experience with the delta 8, but had a stealth unit and a dvir4. Found both to be very fussy. Sometimes I would come check the unit camera and it would look dead. No pictures and the batteries would be fine. Finally the display went all together. Totally useless without a display. In the trash it went. The dvir4 was better, but would get too many whiteout pictures. Tried setting up the camera facing north only and things didnt improve. Lost faith in stealth cams.
 

·
Banned
Joined
·
216 Posts
Had the Stealth U 840 took it back was POS....was eating batteries badly (they lasted two weeks and twenty pics)
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #4 ·
Thanks for the info guys, I was hoping it was something other than the performance of the camera but it seems like it is a Stealth cam issue.
 

·
Registered
Joined
·
2,420 Posts
I have a "the choice" stealth cam and it has amazing battery life, takes really good picture both day and night...
 

·
Registered
Joined
·
158 Posts
I also have a Delta 8 and have experienced the same problems. Very frustrating and it's quite likely I will not buy another.
 
1 - 8 of 8 Posts
Top